Reports slower to process right now compared to normal...
Incident Report for CoverageBook
Resolved
We found the issue and all reports should be processing as normal now. We're monitoring but all systems are back to full speed. Phew.
Posted about 1 year ago. Dec 20, 2017 - 16:54 UTC
Investigating
We've noticed that some reports may appear to be slow to load. Rest assured anything you've added will process. We're looking at resuming normal speedy service asap.
Posted about 1 year ago. Dec 20, 2017 - 16:21 UTC