Screenshot Captures Impacted
Incident Report for CoverageBook
Resolved
Our third party provider has fixed the issue causing delays to some screenshots.
Posted 3 months ago. Jul 12, 2019 - 07:52 UTC
Identified
One of our screenshot providers is having some trouble.

Screenshots are still appearing but you may see some delays.
Posted 3 months ago. Jul 12, 2019 - 05:40 UTC
This incident affected: Image collection and uploading.