Delayed screenshots
Incident Report for CoverageBook
Resolved
The issue some customers experienced with delays in screenshots coming through has now been resolved. We're sorry for any inconvenience caused. Please contact support@coveragebook.com if you have any questions.
Posted 5 months ago. Dec 18, 2018 - 08:06 UTC
Investigating
Images may take longer than usual to upload after adding coverage. Please accept our apologies for any inconvenience caused. We are looking into this and will update once normal service has resumed.
Posted 5 months ago. Dec 17, 2018 - 14:00 UTC
This incident affected: Image collection and uploading.