Ordering of books in the My Books view and client folders
Incident Report for CoverageBook
Resolved
This incident has now been resolved.
Posted 3 months ago. Jul 19, 2019 - 19:35 UTC
Investigating
Some customers may see their books appear in a different order in the My Books view and client folders. Sorry for any inconvenience caused, we're working on resolving this and will update you as soon as we can.
Posted 3 months ago. Jul 19, 2019 - 13:52 UTC
This incident affected: Application.