Issues with uploading and cropping images
Incident Report for CoverageBook
Resolved
This incident has been resolved.
Posted 12 months ago. Feb 07, 2018 - 16:33 UTC
Update
We are currently experiencing issues with images that have been uploaded or edited/cropped. We're currently investigating this issue.
Posted 12 months ago. Feb 07, 2018 - 16:13 UTC
Investigating
We are currently investigating this issue.
Posted 12 months ago. Feb 07, 2018 - 16:10 UTC