Coverage added to book stuck loading
Incident Report for CoverageBook
Resolved
We've now fixed this issue and your coverage should be loading in as normal now. Do let us know if you are still having issues.
Posted over 1 year ago. Aug 21, 2017 - 12:52 UTC
Identified
We are aware of an issue that makes it look like items are stuck loading as you add them. If you refresh the page manually you'll see the results but we're working to ensure this happens automatically for you like normal.
Posted over 1 year ago. Aug 21, 2017 - 12:27 UTC