Reports slow to process right now or not finishing.
Incident Report for CoverageBook
Resolved
We've fixed the issue and reports have been coming back as normal in the last hour. But do let us know at support@coveragebook.com if this is not the case for you.
Posted over 1 year ago. Nov 17, 2017 - 14:55 UTC
Identified
We are aware of an issue that's causing some reports to process much more slowly than normal this morning. We're aware of the issue and resolving now so normal speedy service can resume. Very sorry for any impact this is having to your day.
Posted over 1 year ago. Nov 17, 2017 - 12:45 UTC